1911Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
145 Posts
Discussion Starter · #1 ·
I got my argentine hi power fixed yesterday,my gunsmith put in the new extractor spring,cleaned the grove the extractor rides in and cut the extractor back slightly. He thinks this was the main issue he told me a misscut extractor he test fired her and she ran great no failures.

I also took it in the range and put 150 rounds through her with no failures also,it ran 100 rds. of blazer 30 rds. of winchester white box and 20 rds. of winchester personal defense ammo. Both the 13 round mag it came with and my krd 15 rounder worked fine in it as well,accuratcy was very good actualy for a gun that is a bit lose not as good as my mark III HP but almost,and more than good enough for a CCW gun. this gun does seem to be the most accurate with the cci blazer ammo if this don't sound to odd

As a side note the mag it came with is 13 rounds but takes 14,so what i do is keep it loaded with 14 then when I chamber a round Iam carrying 13 and 1 anyways. I keep her like this due to little ones in the home FWIW. Well thats my range report guys I said I'd update you all on the status of my argei HP when I got it fixed so here it is,I'am sorry theres no pics but I have no clue how to upload them from my digicam I only know how to take them.
:( my bro usualy does it but hes not here for the weekend.
 

·
Registered
Joined
·
192 Posts
Thanks for the report,glad to hear the 'smith got her running.:DThe KRD's work well in both my FEG and Arcus clones.
 
1 - 3 of 3 Posts
Top