1911Forum banner
1 - 5 of 5 Posts

· Registered
Joined
·
601 Posts
Discussion Starter · #1 ·
I have a question. I have 2 Bushmaster XM-15 E2S rifles and I own Bushmaster 10 rd magazines for them. For some reason, the very first rd of the mag will not feed right. The bolt would only slide forward halfway thereby causing a jam. After I clear that first rd, it would cycle fine. This is occurring on all of the magazines. Also, the rd is slightly scratched up on the tip and the brass. Is this an issue? I think it is the magazines although I'm not 100% sure at this point.

[This message has been edited by ZekeLuvs1911 (edited 09-29-2001).]
 

· Registered
Joined
·
1,379 Posts
Your problem is more than likely bad magazines. Try your rifle with a GI magazine, and see how it works out. Also, ensure that you chamber the first round by either releasing the bolt from the bolt release lever, or by letting the charging handle go smartly after pulling it. Do not ride the handle forward.

------------------
"Be not afraid of any man, no matter what his size;

When trouble rises, call on me and I will equalize."
 

· Registered
Joined
·
336 Posts
If yuor rifle is new, clen it throroughly and lubricate it CLP liberally. I had the same problem when I first got my AR even with the GI mags but after thorougly cleaning my rifle, I haven't had any prblems
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top