1911Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
89 Posts
Discussion Starter #1
For the first time today with 2 different magazines,only the first round extracts 50% out of chamber and second round leaves halfway out of mag..so when looking into chamber I see half of both rounds facing bore..I drop mag and first round drops to ground reinsert mag with slide locked back and release slide by hand,not by releasing stop..then rest of mag runs fine..any tips??thanks
 

·
Registered
Joined
·
238 Posts
That's an odd one. There have been several reports of TCM extraction issues but Armscor has been getting on top of it and the problem really seems to be dying down. Did you insert the magazine initially with the slide in battery or locked back?
 

·
Registered
Joined
·
89 Posts
Discussion Starter #3
Slide to the rear..after the clear I did it the same way and the rest of the both magazines and gun were flawless..why only the first loaded round is really the puzzle..
 

·
Registered
Joined
·
89 Posts
Discussion Starter #5
At least 200 flawless rounds before this..cleaned her up will try again soon...its the most fun gun since my judge a few years back..have about 10 1911 and Glocks but this has best trigger and muzzle flash..lol...its out of box trigger better than my sti edge!! And that's saying something..
 

·
Registered
Joined
·
606 Posts
Try a .223 chamber brush. Like mentioned by manual, most of us have had failure to extract but what you mention is a strange one especially if the rest of the magazine runs fine. Steve
 

·
Registered
Joined
·
609 Posts
My RIA GI 9mm is failing to extract after 2 or 3 rounds every mag?
 

·
Registered
Joined
·
297 Posts
When my TCM/9mm combo was new, it would fail to extract the first round fired of the session. All the others would be fine. That was with both the .22TCM barrel and the 9mm one. It hasn't done that since, just the very first time I shot it.
 
1 - 10 of 10 Posts
Top