1911Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
133 Posts
Discussion Starter #1
Hello all,
Trying to disassemble my new CBOB. Spring, plug and slide stop came out easily. Slide, however, seems to be stuck towards the rear. Instructions say to slide it off towards front of frame, but it's stuck and I don't want to force it. Help, what do I do?
Thanks
 

·
Registered
Joined
·
662 Posts
Your post is kind of vague, but it sounds like the problem might be that the guide rod isn't lining up with the guide rod tunnel for you. Move the slide all the way back (if it will move) and try shaking it a little to move the guide rod and try going forward again. You may have to try holding the gun at some different angles to get it just right.

It's not really a problem, but my CBOB did this too. A little bit of filing/beveling to the end of the guide rod will fix it up right away once you get it out.


Chevy
 

·
Registered
Joined
·
178 Posts
Your post is kind of vague, but it sounds like the problem might be that the guide rod isn't lining up with the guide rod tunnel for you. Move the slide all the way back (if it will move) and try shaking it a little to move the guide rod and try going forward again. You may have to try holding the gun at some different angles to get it just right.

It's not really a problem, but my CBOB did this too. A little bit of filing/beveling to the end of the guide rod will fix it up right away once you get it out.


Chevy
That's my guess too.

For future reference, don't pull the spring out until you have the slide off. The spring keeps the guiderod from getting hung up.
 

·
Registered
Joined
·
133 Posts
Discussion Starter #4
The guide rod rattles around when I shake gun. I assume the bushing is still supposed to be on, it is fairly snug. I did get a little movement. Slide went all the way back then when I moved it forward it stuck again about %90 into battery. Certainly didn't slide right off. Getting frustrating!
 

·
Registered
Joined
·
188 Posts
Hello all,
Trying to disassemble my new CBOB. Spring, plug and slide stop came out easily. Slide, however, seems to be stuck towards the rear. Instructions say to slide it off towards front of frame, but it's stuck and I don't want to force it. Help, what do I do?
Thanks

Sounds totally broke! You better send that garbage to me, I'll throw it away for you!:biglaugh:
 

·
Registered
Joined
·
133 Posts
Discussion Starter #10
Thanks for the help and support. Finally figured it out and am ready to take it out for the first time. Will report back.
Regards, Mark
 
1 - 10 of 10 Posts
Top