1911Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
1,064 Posts
Discussion Starter #1
Guys,
I bought an SA Champion recently. The first 50 rounds with the factory mags were perfect. Now I get Failures to Feed on the second to last and sometimes last round of the mag. I get about 2 or 3 of these every 50 rounds. I tried shooting UMC, blazer, speer lawman winclean and Fed America Eagle ammo.
UMC is the worst. The round in the mag will nose dive and not come up, the slide begins to move foward but jams up on the rear end of the cartridge. Heres a break down of the rounds and when the FTF occured.
100 rounds of UMC first 2 FTFs.
50 rounds of Fed American eagle No FTFs
50 rounds of WinClean 3 FTFs last round in the mag.
50 rounds of Blazer 1 FTF.
50 rounds UMC 3 FTF
50 round Speer Lawman 1 FTF.
Do I need to just shoot it more and get in broken in? Or is it something.
I know buy Wilson Mags, but the first 50 rounds were perfect with the Factory mags. I love this gun and want to carry but I dont trust it yet.
Oddly enough I also fired 20 rounds of Hyrdashoks and 20 rounds of Gold Dots and they functioned fine.
 

·
Banned
Joined
·
14,948 Posts
I would continue shooting it, but I would also check your extractor tension. Factory extractors have a bad habit of going out of tune REALLY fast - or not being tuend at all.

I replace all factory extractors with aftermarket ( I like Wilson Bulletproof) before I even fire a new gun.
 

·
Registered
Joined
·
1,987 Posts
It may be the extractor...I had some probs with my Champion at around 7-800 rds...Similar to yours...Shot without any problems for 7-800 and then went to ****...My ejector was soft and literally wore out and my extractor would no longer hold its' tension...You can try a Wilson mag first...You can't go wrong there...If it doesn't work, you can always sell it. Here are some links...Keep in mind that if the problem is reproducable, SA will have you ship it to them and repair it...If not, well...best to isolate it first if possible...

Have you returned to the range yet or were those failures during several sessions? Have you completely broken it down and cleaned it thoroughly and re-lubed it yet? These are kind of important as it's not clear from your post...
If you haven't shot anymore than that and the pistol has NOT been cleaned. I would clean and lube it before ANY other course of action. You may even SEE the problem while doing so...

Here's the links...Let us know the rest of the story...


http://www.sightm1911.com/lib/tech/reliability_secrets.htm
http://www.sightm1911.com/index.htm
http://www.m1911.org/m1911dt.htm
http://www.m1911.org/technic.htm

Good luck and let us know




------------------
>>>>>>>>>>g2<<<<<<<<<<

I Like The Shade Too!
 

·
Registered
Joined
·
1,064 Posts
Discussion Starter #4
Okay,
Yes I have cleaned and lubed it.
All of these were during several different trips to the range. I am not sure how the extractor would be to blame but I am new to 1911's. Everything looks okay to me when I break it down.
Like I said the Round nose dives and the slide moves foward jamming up on the rear of the nose dived round. That is why I dont think its the extractor. I am going to have the local 1911 guy LOOK at it tomorrow. If he sees anything wrong back to SA it goes.
I hope its just break in woes, beacuse I really like this gun.

[This message has been edited by MattK (edited 05-29-2001).]
 

·
Banned
Joined
·
14,948 Posts
Matt, if the extractor is too tight, the round will have difficulty slipping into the notch, and you will get FTF as a result.

Check out gyp_c's links - you will find some tips on tuning the extractor - or search the archives in this forum under "extractor" or "tuning". Good luck.
 

·
Registered
Joined
·
170 Posts
Matt -

I had the same sequence of problems. After futzing around with polishing and adjusting the stock extractor with no positive results, I bought a Wilson Bulletproof extractor at a gunshow.

Presto! No more FTFs!

Since the piece is life-time guaranteed, I would say the slow answer is to send it back to SA for an extractor fix - the quick answer is to replace the extractor yourself.

HTH!

Tony

------------------
Eagles may soar, but weasles don't get sucked into jet engines...
 

·
Registered
Joined
·
1,064 Posts
Discussion Starter #9
Alright I was horsing around at lunch. Making sure the pistol was clean and collecting my mags and such. Well well I have been using a Metalform mag in addition to the factory mag. The Metalform mag fits oddlly into the gun. The front of the base pad is flush but the rear of the base fits further up into the handle of gun. Has this been causing my problems all along? I am I a complete idiot? Both are possible. I will do a nice little test this afternoon at the range and see what happens.
 

·
Registered
Joined
·
1,064 Posts
Discussion Starter #10
This isnt definite but I am pretty sure its the mags. I bought a Wilson mag it worked 100% I switched to factory mags, EL Jamo! back to Wilson 100% The smith is pretty sure its the mags. He wants to send the factory mags back to SA. I will continue to shoot it with all Wilson mags for 2-300 rounds and see what happens.
Thanks
 
1 - 10 of 10 Posts
Top