1911Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter #1
I'm having trouble with my SA Mil-Spec 1911A1 feeding. It fires the round okay, ejects the spent case okay, but it hangs up feeding the next round. The round strips forward, but doesn't ride up the feed ramp very far. If I pull the slide back a half inch and let it loose, it usually chambers the round. It sometimes happens when dropping the slide on a new magazine or when feeding during firing.

The problem has occured with both PMP and IMI .45 ammo. It has also occured with the SA factory magazine and two Chip McCormick 10 rd mags fully loaded or loaded with 7 rounds.

As a note, I only had one or two of these FTFs during the first 100 rounds or so. Since then, it happens almost every magazine, usually within the first round or so.

Initially I thought it was hanging on the extractor, but a closer inspection seems to indicate that the nose of the bullet is rubbing on the feed ramp. After a few magazines, I wiped the carbon off of the feed ramp and noticed a couple spots where the copper jacketed bullet was leaving rub marks. It sure looks like the bullet is dragging a little too much, as I have never really noticed this on my other pistols (9mm, .380, .32)

Can this be fixed myself? Is it as simple as polishing the feed ramp? If so, what's the best method? I have a Dremel and polishing tips at my disposal.

Thanks in advance,
LL
 

·
Registered
Joined
·
10 Posts
I had the same problem with my Mil-Spec,I took it to a gunsmith and had him polish up the the feed ramp and he adjusted my mags the one that came with the gun and 3 cmc shooting star 8 round mags.
I was mainly having trouble w/200gr.swc and after about 1200 rds. thru it the gun runs smooth with about anything I put in it.

Hope this helps a little.
 

·
Registered
Joined
·
26 Posts
Discussion Starter #3
Well, it does help. A little. I just don't have any gunsmiths around here I know.

Seems like easy enough job to do myself, but nobody wants to give any pointers. I guess people just don't like me or something. :/

Oh well, nevermind, I guess I'll live with it like it is, back of the gunsafe, useless.
 

·
Registered
Joined
·
1,060 Posts
Try the "Maintenance & Troubleshooting" forum. I had a minor problem with my Mil-Spec and received a lot of helpful advice from those guys.
 
1 - 4 of 4 Posts
Top