1911Forum banner
1 - 1 of 1 Posts

·
Registered
Joined
·
95 Posts
Discussion Starter · #1 ·
Alright. So, I took my brand spanking new Pro BP Ten II to the range today, to put a couple hundred rounds thru it. Here's what I found out:

First of all, this thing is very accurate. I was very impressed by that. Just as accurate, if not more accurate than my Pro Eclipse Target II. I was using Federal American Eagle 230gr ball ammo. I used a single 13rd Mec-Gar magazine, all metal w/ the flush fitting baseplate. The only one supplied with the pistol.

The first thing I noticed about loading the magazine, is that around round 6/7 the round would lay flat, and not "nose up" into the feed lips. A gentle tap and it would pop into place. Not sure if this is a issue, or not. Once I started shooting, I tried shooting full 13rd mags first, to see how it performed. I had a couple stoppages with two, or three rounds left in the mag. I thought at first that the round had jammed against the feed ramp, when in actuality the slide locked to the rear. A quick flick of the slide release, and I was back in business. Not sure if maybe my thumb bumped it or what. That happened maybe three times. Another time the pistol failed to go into battery. Never had that before. The hammer was back, pulled the trigger, and ...nothing happened. Then I noticed I had about 1/8" to fully into battery - a tap - and bang ... back in business. This happened only once.

All in all, I think it was a success. I hope these problems will subside once I put another 300-400 round thru it. I field stripped it out of the box, and oiled liberally. I also added a small bead of oil to the rails during the course of fire.

Of course, once I got home I field stripped it again, and cleaned it thoroughly - everything seemed to be in order. Cleaned the magazine too.

So, that's my Pro BP Ten II range report.
 
1 - 1 of 1 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top