1911Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
First post on any forum, but long time learner from everyone here.

Got my first 1911, a "blue" Kimber Custom Target - only a 100 rounds so far. Upon cleaning after the last range session I noticed some "damage" on the inside of the slide. Want some guidance on whether this is normal or not.

Looking at the slide upside down, just back of the recoil spring cap housing, there are wear marks on the inside of the slide on both sides of the slide rails. It looks to be caused by "head" of the recoil spring guide rod when the slide comes back during operation.

Is this normal, is something wrong, or am I just being overly concerned?

Thanks to all for sharing your knowledge, opinions, insight and experience on this board.

[This message has been edited by Yoks (edited 11-20-2001).]
 
Joined
·
66 Posts
That I know of the guide should'nt contact the slide at all. Just the barrel and reciever and not scuff or damage in 100 rounds at all the points it contacts. Something could be amiss in Kimber land my friend.
 

·
Registered
Joined
·
2 Posts
I Custom model and mine does the samthing. There is actually a very small chunk missing where mine is wearing. I am assuming it is normal wear from the recoil spring making contact with the slide during compression. I have never called or contacted kimber though. But now I will. Email me and if you have anymore questions.

[email protected]

Justin
 

·
Registered
Joined
·
2,395 Posts
Through the first 100 rounds, did you have functioning problems? If not, I wouldn't worry about it. Apparently not bad enough to slow the slide down. If it got really ugly, I'd contact Kimber and see what the deal was.
 

·
Registered
Joined
·
417 Posts
I have no experience with Kimber, but if they follow the Colt in both design and tolerances, then the spring guide should not contact the slide. If it is, then you have a potential problem.

Do the corresponding sides of the spring guide also show wear? How far do the wear marks on the slide extend? do they begin and end at places on the slide that are adjacent to the guide?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #6
Thanks for the replies - been offline since Thanksgiving (Hope everyone had a good one) so apologies for the delay

The artis, Kaneman23 - thanks. I'll also contact Kimber.

col132 - no functioning problems even with factory mag and Blazer ammo

feedramp - IIRC, "head" of the spring guide, (rear most against frame) show no wear - will check tonite. If you install the FLGR without the recoil spring, and push forward until it reaches the recoil spring cap housing, the marks are on both sides of the slide, and are about the same width as the "head" which led me to believe this was hitting slide. No other marks along the rest of the slide.

Sorry if I got the nomenclature wrong.

Thanks again to all.
 

·
Registered
Joined
·
2 Posts
YOKS,

I haven't had a chance to contact Kimber yet but if you hear anything before me, please let me know. I have been worried about mine for quite sometime now.

Thanks,
Justin
 
1 - 7 of 7 Posts
Top