1911Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
413 Posts
Discussion Starter #1
Maybe this has been asked before but here goes. After about 1000 rounds my RO slide started intermittently locking back before the mag was empty. In the last 200 rounds it has done this 3 times. Anyone know what I can do to stop this from occurring? I hate to send it back to SA for such small problem.
Thanks for your help.
 

·
Registered
Joined
·
452 Posts
A number of things can cause that....

My favorite is weak magazine spring. Try a new, high quality mag and see if that fixes things.
 

·
Registered
Joined
·
2,457 Posts
If you are sure you aren't riding it I have seen some bullet profiles that hit the slide stop tab and push it up to lock, if that's the case you need to file it a bit.
Not sure what type of ammo you are using but look on the stop tab for copper marks.
 

·
Registered
Joined
·
169 Posts
If you are sure you aren't riding it I have seen some bullet profiles that hit the slide stop tab and push it up to lock, if that's the case you need to file it a bit.
Not sure what type of ammo you are using but look on the stop tab for copper marks.
This^
Have you changed ammo? Maybe new brand of bullets for reloading?
 

·
Registered
Joined
·
4,928 Posts
Does your slide stop look like this?


The brass kiss indicates that the round traveling up the magazine is hitting the slide stop lug, thus causing the slide stop to engage the slide stop notch in the slide as the gun cycles.

All that is needed is to file the brass marked area down until the round no longer makes contact with that area.

It's a 5 minute fix.
 
1 - 6 of 6 Posts
Top