1911Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
121 Posts
Discussion Starter · #1 ·
I'm gonna call cs and know they will work it out, but everything i read sounds similar to my problems, but my searchers aren't turning the answer. I have a 1911 scorpion government. i get failure to go into battery when dropping the slide on the first round and failure to go battery midway through the magazine? Cant push it into battery but i can eject by racking the slide. Does it with both factory mags and 2-47's? Any thoughts on the actual issue. over 500 rounds with various production 230 rn. So what's sigs fix for it?
 

·
Registered
Joined
·
8,321 Posts
I don't know what Sig's fix for it but I have commented on some of my theories in other posts.

Just read all the failure threads on the first page here.
 

·
Registered
Joined
·
121 Posts
Discussion Starter · #3 ·
Still doing the searches and I get throating and polishing the barrel maybe a fix, but these are production guns so why do some run and some don't? I'm not an armorer, just know enough to be dangerous. If you have knowledge, through it out there I would like to hear it
 

·
Registered
Joined
·
8,321 Posts
No searches needed. Just read the failure threads on the first page of the Sig subforum. I'm not trying to be difficult. It's just, I don't want to type it all over again.

The short version is I find rough or under sized chambers, rough breech faces and tight extractor hook to breech face clearance on some of them. I would also like to check feed ramp angle, barrel ramp to feed ramp gap and headspace.


What I would really like is for someone to send me a problem gun so I can do a detailed write up on what I find and send it to Sig.
 

·
Registered
Joined
·
121 Posts
Discussion Starter · #5 ·
I'll look again, not being difficult at all. Just typing and watching football, maybe more watching football. It's all good.
 

·
Registered
Joined
·
205 Posts
The only thing that has caused failure on first round for me were crappy lead rounds. But you said you've tried various ammo so that rules that one out. Sig will probably polish and throat it, their standard fix for everything.
 

·
Banned
Joined
·
329 Posts
I had the same problem on my Ultra Limited. Push up on the magazine from the bottom, like resting it on your palm while racking the slide or shooting. If the problem goes away there may be too much play in the magazine. Forcing the magazine up raises it in the frame and may be what it needs, like mine. Lock the slide back and install a full mag and see what kind of up-n-down play is in the magazine, I had like .038" If you know anyone that has some Tripp or Wilson Combat magazines try them. I cured mine by installing an EGW higher magazine catch, which holds the magazine higher in the frame, thus the bullet higher up the feed ramp, and Tripp Research Cobra magazines, problem solved. You may have to take a little meat off the ejector inside corner if the rounds rim hits it. She feeds so much smoother, I can hear and feel the difference.
 
1 - 7 of 7 Posts
Top